Skip to toolbar
Press "Enter" to skip to content

Welcome Testers! Updates On This Thread…

Okay folks. This is a work-in-progress version of a New Babbage Community site, intended as an eventual replacement for the Ning. Most of the requirements are installed and working, but things are clearly in motion. Interface especially, and finding the links to do all the stuff you want to do. For example:
  • The Ning lets you create new content by clicking links near the blog/discussion/image areas; Community puts those links in the right column.
  • Posting new content to the Ning only involves a few choices; posting it here involves a bewildering array of choices. They’re optional, but possibly confusing.
  • You have to send someone a message from their avatar profile – there’s no Inbox link

The good news is that (unlike the Ning) it’s all – or mostly – changeable. Please post your feedback and improvement suggestions to this thread as you poke around, and we’ll fix or improve them as best we can. It’s all ours, too – we don’t have to wait for a company to add a feature or change something we don’t like – so don’t be shy about imagining ideal solutions to things. Mods: please create new accounts and let AE know so I can give you mod privileges.

TO DO LIST:

  • install security update – DONE 6/18
  • improve recent activity display in left column – BETTER 6/20. Big problem: It only includes original content, not comments. OUCH
  • improve styling on the Event Calendar
  • replace WYSIWIG library with a better one, or add Containers and Classes to the one we have. Should this be the editor by default?
  • tweak formatting to see if we can create “Add [Content Type]” buttons near the block/page displaying that content type
  • extend Recent Discussions/Recent Blogs to include last-post date, last post avatar, etc. – DONE 6/20
  • improve styling on delete/edit/reply links
  • improve styling on image-upload and WYSIWIG/add-link popup
  • improve styling of Galleries node
  • remove ‘next discussion’ link from bottom of discussions
  • further develop Build Record content type
  • explore a node with a taxonomy index – so you can view all elements tagged with a given value (there’s a View for this pre-made… would be cool to turn it on)
  • improve styling on section separators
  • add SL integration module?
  • add chat module?

Plenty of bugs and formatting annoyances too. Add those here. Cheers!

Spread the love

20 Comments

  1. Cyan Icewolf Cyan Icewolf June 18, 2010

    Love the recent activity but then it gets all funky in the end. Also not sure but it seems the image in the previous thread disappeared. But it’s looking good so far :3

  2. Lia Bilavio Lia Bilavio June 18, 2010

    Noticed this formatting error when looking at the previous thread: 

    another note, when uploading the image to add to this comment, it’s not inserting it into the comment field or if it is, it isn’t showing it as being inserted.

  3. Cyan Icewolf Cyan Icewolf June 18, 2010

    Also the recent activity isn’t fully updating as it doesn’t have my post to this message listed. Also I think the links provided don’t lead to the actual reply but the original content instead.

    • Cyan Icewolf Cyan Icewolf June 18, 2010

      Actually looking further it doesn’t seem to be posting anyone’s replies at the moment

  4. Cyan Icewolf Cyan Icewolf June 21, 2010

    The front page is looking good so far. :3

    • archivist archivist June 22, 2010

      Thanks. Formatting is in pretty good shape. The activity feed lacks comments. Maybe two separate sections? Hmm.

      • archivist archivist June 23, 2010

        So it will only log “activity” messages as they are produced, not after the fact? Hmm.

        • archivist archivist June 23, 2010

          Once you get over that, it works perfectly. It took me a bit to get the right syntax in there, but I think that should do the trick. NICE, Cyan!

          • Cyan Icewolf Cyan Icewolf June 24, 2010

            Now the only thing still left is trying to link it to the actual comments.

            Also wanted to still test to see if the paragraphs are working. [EDIT]Well apparently paragraphs aren’t working still (which I think might be because of of limited HTML or even the HTML configuration for WYSIWYG) but on the subject of comments if there is some way we can access the comment admin settings where you see every comment to work with the activity module. Not sure how to do that though.

            • archivist archivist June 27, 2010

              Aha! There was a bug in my activity template settings. I think subsequent comment logs will be linked to the specific comment. We’ll see with this one…

  5. Cyan Icewolf Cyan Icewolf June 22, 2010

    Somehow the right side panel is now in the lower middle section.

  6. archivist archivist June 23, 2010

    Okay I’m stumped. I can’t get ImageAssist to dump inline tags into comment fields successfully when WYSIWIG is enabled. It works fine when it’s disabled, and usually when I have the Input Format as FullHTML, but I can’t for the life of me get it to insert a tag when WYSIWIG is on. I tried two WYSIWIG editors and got no joy.

    Any assistance would be appreciated. It *was* working – and I don’t know when or why it stopped.

    • Cyan Icewolf Cyan Icewolf June 23, 2010

      There doesn’t seem to be a post image icon through the WYSIWYG links. Maybe it has something to do with that (basically not allowing it because the function just isn’t there).

      Edit. Scratch that now that I see the image icon :P

      Lets see if this works.

      [Second edit] No it doesn’t… and at the same time it’s also taken Paragraphs out as well. I did do a search on drupal though: http://drupal.org/search/apachesolr_search/image%20assist%20and%20wysiwyg

      • archivist archivist June 29, 2010

        Sorted it out. img_assist only works with TinyMCE. Installed, formatted, tested. Works. WOOHOO!

        So what’s left? I think we can start inviting the mods. Should I delete the test content?

        • Cyan Icewolf Cyan Icewolf June 29, 2010

          Woohoo!

          Now lets figure out what else we need fixed heh.

           

          Paragraph spacing is still not working.

  7. Victor1st Mornington Victor1st Mornington June 25, 2010

    800kb for an image upload aint enough…not if you want folks uploading high resolution wallpaper type snapshot, there would be no chance that city wide full top down view pictures could be uploaded in an 800kb image size…

    …and i cant find a way to upload pictures to the gallery either :(

    • Cyan Icewolf Cyan Icewolf June 25, 2010

      It’s all in the create content section. Although would be smart to put a link in the gallery section to add images as well.

      • archivist archivist June 27, 2010

        The upload size is set to 2048K, I think.

        [img_assist|nid=67|title=|desc=|link=popup|align=left|width=422|height=429]

        Where did you find the 800K limitation?

Leave a Reply