Skip to toolbar
Press "Enter" to skip to content

Bugs and Feature Requests

Update!

Things we are working on currently:

Delete own Comments

Follow Content without a comment

Login for this site should also work for the Wiki

Bulk E-mail to Users

Things we continuing to work on:

Fix PNG Thumbnails

Better User Profiles

Fix North Fells SL Link

Feature Location Repeating Text

Inspiration Isn’t Showing (Build Directory)

Blog Rolling

Drop Down Menu for Character Status (IC, OOC)

Things that have been taken care of:

Profile Photo Link

Attach to event causes an error

Personal Galleries

TinyMCE Strikethrough and Underline

Rich Text no longer adding paragraphs

If there is anything on these lists that shouldn’t be where they are please let me know.

Please continue to post any issues or feature requests here.

Spread the love

109 Comments

  1. Archivist Archivist August 14, 2010

    I think these are automatically rising to be displayed on the home page… I’ll go turn that off.

    • Cyan Icewolf Cyan Icewolf August 14, 2010

      Just did. Or at least the issues.

  2. Archivist Archivist August 14, 2010

    Awesome. So you want to keep this node on the front page?

    Can I suggest that we include it in the ‘moderator shortcuts’ menu instead of the main one?

    • Cyan Icewolf Cyan Icewolf August 14, 2010

      Yes that would be good. And I think having it in a place were everyone can see it would be good too at least for now.

    • Archivist Archivist August 14, 2010

      I moved the Issues link but can’t figure out how the My Projects link is appearing to turn it off. Oh and I can’t add it to the moderator menu either. Weird.

  3. Mr Underby Mr Underby August 16, 2010

    The formatting I created in a recent blog seemed to be ignored once it was published?

    • Archivist Archivist August 17, 2010

      Mr U – was it HTML or stuff you added with text editor buttons? If the former, only certain tags are supported (there’s a list of supported tags in the “Input format” block below the comment form). If the latter, it might be a glitch in how we’re processing text submissions. What formatting did you add, and which post was affected?

  4. Mariah Lanfier Mariah Lanfier August 19, 2010

    I was trying to put a link in my blog post, and it looks like doing that wipes out all the text of that post.

  5. Edward Pearse Edward Pearse August 19, 2010

    I’d still like to see a means of following a forum/blog without having to actually reply.

  6. Scottie Melnik Scottie Melnik August 20, 2010

    On the front page under “Blog Posts” I see everything set to August 8. The times seem right and when you click on “View All” or go into a post those dates are right, it just seems to be on the front page.

    • Archivist Archivist August 26, 2010

      Fixed. It was displaying the number of the month the post was created, not the number of the day. Ah, PHP shorthand.

  7. Amber Ilsker Amber Ilsker August 23, 2010

    When I first registered for the forum, after relogging an hour later my password wouldn’t work, I did the forgot password thing and put in the exact same one it worked fine. I reloged to check, fine. Now today a couple of weeks or more later I tried to log in and my password wouldn’t work, so I did the same step again used the same exact password and got in today. Any idea how it keeps saying my passwords invalid after it has worked previous times ?

    • Archivist Archivist August 26, 2010

      I’m afraid not. We are approving membership requests, so one explanation for why your password didn’t work immediately the first time is that your membership hadn’t been approved. No idea why it didn’t work the second time. Sorry for the inconvenience – we’ll keep our eyes open for other reports like yours.

  8. Marian Dragovar Marian Dragovar August 24, 2010

    Hoping this is in the right place! Feature request:

    Content to be added to the FAQ section:

    -How to create an event
    -What a SecondLife terminal is and how to verify your account or whatever that’s about

    • Archivist Archivist August 26, 2010

      Excellent suggestions. Both are done.

  9. Amber Ilsker Amber Ilsker September 2, 2010

    Hi, I just added 2 pics to the steampunkesque gallery…..

    But when you use the Gallery tab at the top it doesn’t bring up that gallery, only the municipal one, so will any images put in the steampunkesque one be accessable once they fall off the front page ?

  10. Gabriell Anatra Gabriell Anatra September 3, 2010

    Something somehow, has broken the page display across the entire site in firefox. It looks like this now:

    [img_assist|nid=590|title=|desc=|link=popup|align=left|width=640|height=481]

    • Cyan Icewolf Cyan Icewolf September 3, 2010

      I’m currently using Firefox on Windows and don’t see it.

      What OS are you using? Not sure what could cause it though really.

      • Cyan Icewolf Cyan Icewolf September 3, 2010

        Actually may have some idea what may be causing it (some of the upper layer images not loading) but not sure how it’s happening.

    • Archivist Archivist September 3, 2010

      I see this when the background graphic doesn’t load completely. When you reload does it stay that way?

      • Gabriell Anatra Gabriell Anatra September 4, 2010

        It loads this way and stays. Re-starting the browser doesn’t change anything either. I installed a plugin yesterday that might have something to do with it. It’s only supposed to block trackers though, but false positives are possible. I’ll disable it next and see.

        Nope, no good. The plugin is disabled and no change. I’m running v3.5.7 of Firefox here on Ubuntu 9.10.

        • Archivist Archivist September 4, 2010

          Were you seeing the background graphics before you installed the plugin? Do you see the same problem with other browsers?

          • Gabriell Anatra Gabriell Anatra September 4, 2010

            It just broke the day I made that first post in this sequence or the day before.

            It works in Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.10 and Chrome 5.0.342.9 beta.

            It loads slowly in Chrome though. Slow enough to see the background images loading. I think they aren’t being displayed in areas that aren’t immediately visible. It’s mostly the parts of the page that are not visible without scrolling that are affected.

            Also turning page style off allows me to see the page, but prevents posting or entering text. So I can either see what I’m reading or talk about it. Not both.

            Maybe I’ll switch to Opera for this site?

            • Archivist Archivist September 4, 2010

              Well that would be a shame. It runs fine on Chrome 5.0.375.127 (Windows 7) for me, although I do see the background images as they load the first time. Once they’re cached it’s fine. (That’s my bad – I wasn’t paying much attention to image size when I built the theme and never went back to shrink them down/)

              So maybe it’s the OS? Or that plugin you mentioned? Have you looked at it with Chrome’s Inspect Element feature? Maybe you’re overriding the CSS for some reason.

              • Gabriell Anatra Gabriell Anatra September 6, 2010

                Chrome still works better than Firefox. It’s unusable for this site now. The OS hasn’t been updated recently so it’s not likely to be that. Well, I’ll install a new version of Firefox and see if that fixes it. If not it’s on to Opera then.

                 

                UPDATE: I installed 3.6.4 today and tried it. It works in this version. I guess somebody sacrificed a black cat with three white hairs by the light of the full moon on a wednesday the 13th. :-P

  11. Bela Lubezki Bela Lubezki September 9, 2010

    i seem to not get any private messages in here. i get them forwarded, but i have no clue where to look for them. (safari 5.0.2)

    behind my “My Page” tab i get: view-edit-secondlife-track-community-signups

    any hints and ideas? 

    • Cyan Icewolf Cyan Icewolf September 10, 2010

      We’ll look into it. In fact I’d prefer to get a bit of a better notification of friend requests, messages and other things myself.

      • Bela Lubezki Bela Lubezki September 22, 2010

        i still can not find a place where personal messages adressed to me arrive. i seem to miss the proper tab. i did see this tab in the profile of many other BAR inhabitants (called “contact”) but not at mine.

        i suspect that i have to switch it “on” somewhere. perhaps someone could provide a description of the path where to set such things.

        … perhaps no one tried to contact me so far…

        edit: oh, i found the place behind the curtains, where you BAR-mechanotricians discuss all the stuff and try to keep the fires in the engine compartment low. 

         

        “Reply by Cyan Icewolf | Thu, 9 September – 7:37 pm SLT

         

        I think we should get this: http://drupal.org/project/privatemsg it would help with the messageing situation”

        thanks, there is hope and keep the good work up

         

        • Edward Pearse Edward Pearse September 22, 2010

          We have messaging capabilities?

        • Cyan Icewolf Cyan Icewolf September 22, 2010

          I’ll install this tonight and set it up, see how it works.

  12. Tesla Tripsa Tesla Tripsa September 10, 2010

    I might just be missing it, but can we get a link to the real estate listings in the resource guide on the front page like we had on the Ning.  I eventually did find the thread, but there weren’t any posts on it, possibly because it’s not as prominent?

    • Cyan Icewolf Cyan Icewolf September 10, 2010

      I found the one too. I thought Tenk had updated it at some point. I will post a link to it on the front pages for prominence.

      • Sky Netizen Sky Netizen September 10, 2010

        On that note, is there a good noticeable link to the Wiki? I could possibly just not be seeing it.

        • Cyan Icewolf Cyan Icewolf September 10, 2010

          Archives at the very top :3

  13. Stargirl Macbain Stargirl Macbain September 15, 2010

    Hey, got a bug-in-my-ear to try the “tales” feature for a series of shorts I’m doing to wrap-up some in-world RP business over the next few days and after I posted it I realized I have no idea where it goes.  It doesn’t appear in “Blogs” and it doesn’t appear in “forums.”  Does a tab need to be added somewhere or am I blind as a bat? 

  14. Cyan Icewolf Cyan Icewolf September 16, 2010

    Well we have a idea for adding a drop down menu for in and out of character posts.

  15. Edward Pearse Edward Pearse September 17, 2010

    Can we get a “Delete comment” button?

    • Cyan Icewolf Cyan Icewolf September 17, 2010

      We are trying to work on that one. Unfortunately all I have seen so far gives everyone the right to delete all comments which doesn’t really help.

      We will continue looking though as it is something a lot of people want.

  16. Edward Pearse Edward Pearse September 22, 2010

    Is it possible to change the friending system to make request notifications more obvious? At the moment you have to go to your page, then the track tab, then the received link. So unless you actually know it’s there, or bother to check it every now and again, you’ve no idea you have a request.

    • Cyan Icewolf Cyan Icewolf September 22, 2010

      I’ve been wondering that myself. I will dredge the drupal website for something and try to set it up tonight if possible.

      [edit] This looks like a good starting point and will test it out tonight:

      http://drupal.org/project/flag_friend

    • Archivist Archivist September 22, 2010

      I think this is more about the layout of the profile page than the module itself. I have a second-generation profile page in development right now, but it’s not ready, and when I work on it I bring the site down (that’s what happened earlier today).

      The problem is this: our hosting company has a limit on the number of database transactions allowed in a given hour: 75000. It’s to serve as a failsafe against sites that come under a DDOS attack, and there’s no way we should come anywhere near this number. But for some reason after I do 20 minutes of work in the Views module I breach the threshold. It doesn’t make any sense and I’m looking in to what’s going on, but in the meantime progress on the new profile page is being thwarted.

      • Cyan Icewolf Cyan Icewolf September 22, 2010

        Was wondering why the site was down (although figured it was something like this actually).

        Have you checked Drupals website on this issue? They may have gotten a solution that we may be unaware of.

      • Cyan Icewolf Cyan Icewolf September 23, 2010

        Also since you are doing this I won’t touch anything for now.

  17. Cadmus Lupindo Cadmus Lupindo September 23, 2010

    Received an email from someone using the BAR message. In the BAR is shows no messages received. Good thing I checked my email account. Now can we respond to the message in the BAR or is that through external email?

    • Cyan Icewolf Cyan Icewolf September 24, 2010

      That is a good question. I don’t think so I think you have to use the BAR in order to reply. We are working on this though and will hopefully get some sort of messaging thing for the Reader.

    • Bela Lubezki Bela Lubezki September 24, 2010

      i started to think i was the only one with this parametrization

  18. Serafina Puchkina Serafina Puchkina October 6, 2010

    I’m uncertain whether this question belongs here, or if it’s worth starting a separate discussion thread. There are so many blogs on this site with so many rp storylines going, that I am unwilling to spend the time deciphering whose blog relates to what storyline.

    This is NOT a complaint about the blogs. NO. I’d like to get caught up on the storylines, but I don’t know who belongs to what, how they relate, even how many different rps are currently going on. I don’t know where to start, whose to read next, and so on. If the blog operates as it’s done in the past, I know that some are stand alone blogs and are not part of any Babbage-wide rps.

    At the risk of appearing supremely lazy, quick summaries, as in “here’s what you need to know to get started in this rp” would be nice. 

    I assume some rps are closed to newcomers, and that’s fine. Perhaps some are open to latecomers as well. 

    Surely I am not the only one here. 

     

     

     

     

    • Cyan Icewolf Cyan Icewolf October 6, 2010

      That is a good concern. Unfortunately with all good Babbage RPs we never know who is involved or what’s going to happen next ourselves. Even the best bet is to string them together (which we can accomplish here and through the wiki) but usually that’d be after they have already been done or at least once they fully get started and we figure out there’s an actual storyline going on here.

      The problem that happens (with a lot of RPs) is that a story may start but never get off the ground or gain enough momentum to use the stringing ability that the drupal site does have.

      Just to give a brief description of what the site can do: It can set up a main story and have threads linked to it to make chapters in a book. I used it for some of my stories years ago for my drupal site and it worked quite well.

      We can look into implementing something like this but I think a lot of it accomplished by the wiki so not sure how or if things will change from that.

    • Bookworm Hienrichs Bookworm Hienrichs October 10, 2010

      There’s also the Current Events page on the Wiki: http://cityofnewbabbage.com/records/index.php?title=Current_events
      I do write short summaries of each post, so that might help you find the ones you’re interesting in.

      But yes, as Cyan said, there’s not a lot of post gathering that can be done until the RP has run its course, unless it’s certain that it *will* run its course, and not be dropped or interrupted. The question of helping people get in mid-stream is something for those doing the RP–that, I think, could be a good discussion thread.

  19. Glaubrius Valeska Glaubrius Valeska October 6, 2010

    Would it be doable to add a Video tab to the homepage?  The Texas Steampunk website has one and there is a guy that puts some really fine items there.  Tho I can imagine it might be a bandwidth problem, or just a pain in the nether region what with copyrights and permissions and such; still, I thought it would not harm to ask.

    • Cyan Icewolf Cyan Icewolf October 7, 2010

      I think I’m going to defer the logistics of that one to Archivist personally because I’m not sure of the amount of space or bandwidth the site has (or if drupals video system might drain the bandwidth as well).

      On the other hand I’m sure there is a Babbage Youtube page we can link to (or if there isn’t there should be). In fact maybe we should have a whole section for Steampunk links that maybe of interest too Babbagers inside and outside of SL.

      We will continue to look at why we can’t easily put videos into the posts though (I remember it was a long and annoying process before).

    • Archivist Archivist October 13, 2010

      Hmm. Well, there’s no content type (right now) for video explicitly, but embedding a video hosted elsewhere can be done in any content type, just by slapping in the code. Doing it this way would avoid any hosting space problems, and the bandwidth issue would be between the viewer and the place the video is actually hosted, so it’s probably best.

      As for grouping them all together, we could create a new content type and then build a view that displays all the nodes of that type, or we could make sure that any node with an embedded video had a specific taxonomy tag and create a gallery to display nodes with that tag.

      Do you think we have a need for uploading/storing custom video/machinima? Or would it just as easy to upload stuff to YouTube and embed it here?

  20. Edward Pearse Edward Pearse October 18, 2010

    I just went to try and find if something else had already been posted and discovered there’s no search mechanism within the forums.

    Could that be something we add on at some point soon?

    • Cyan Icewolf Cyan Icewolf October 19, 2010

      There is a search feature on the home page but it doesn’t seem to be anywhere else. As I’ve never tried that either I don’t know how well of a search it does.

      • Aeolus Cleanslate Aeolus Cleanslate October 21, 2010

        Search works pretty well, I think. We can put it on other pages, but that right column is getting pretty crowded.

        • Edward Pearse Edward Pearse October 21, 2010

          I’ll just have to remember it’s on the  front page.

          Unless putting it on a tab up the top? Dunno. Just thinking.

          Still, at least we have one and now I know where it is it’s come in handy.

  21. Edward Pearse Edward Pearse November 2, 2010

    I think there’s a problem with the Gallery feed. Two recent photos, Mr. Tenk’s No. 7 and Skyler’s First drink of Rum are showing in the recent history bar on the side of the front page, but neither show up when you click on the Gallery proper.

    • Cyan Icewolf Cyan Icewolf November 4, 2010

      I try to comment to every one of these but this one I am unsure of as the Galley, I think, is using a different program so I don’t know what the correct response for this one would be. One thing though is they may have not been added to the Municipal Gallery but another folder (as the main gallery only shows the Municipal Gallery Folder).

      • Wallis Graves Wallis Graves November 4, 2010

        Is there another folder apart from the Steampunkesque Gallery? Maybe it’s worth making the default dropdown menu the Municipal gallery so they don’t vanish into the aether after they fall off the *recent* feed?

        • Cyan Icewolf Cyan Icewolf November 4, 2010

          There are two different folders; The Steampunk Gallery, and the Municipal Gallery.

          It would make sense to have a drop down menu for the different galleries though or if anything just show images from all galleries.

          • Doctor Obolensky Doctor Obolensky December 5, 2010

            My event for the ornament contest keeps disappearing off the event listing.  ?

            • Archivist Archivist December 6, 2010

              I had the same problem with the Fleet Week announcement. I think the event view only shows events that start in the future, so once the event start date has passed it thinks it’s over.

              I futzed with it a bit and couldn’t fix it, and then came up with a workaround: set the official start date to be the same as the end date, but put the real dates in the subject line. That has the appropriate effect.

              I did that to your event – but the view only shows six events at a time and technically yours is number 7. (Doh!) I’ll take another look at the logic and see if I can get it to work properly.

              • Doctor Obolensky Doctor Obolensky December 7, 2010

                Yeah, and if I bump mine up, somebody else gets bumped off the list.  I guess it will just have to be a stealth contest for awhile.

                 

  22. Aeolus Cleanslate Aeolus Cleanslate December 22, 2010

    Hey folks. As we near the end of this year, we probably ought to go back and boil this thread down to the issues that are still unresolved, and then retire it in favor of a new one. If anyone feels like doing so, please feel free!

  23. Sky Melnik Sky Melnik April 5, 2011

    As of last night errors have been popping up for me. It’s not a browser issue since it’s popping up on both Firefox and Safari. It happens whether or not I’m logged into my account. It might easily be something that will straighten itself up in a day or two, but I figured I’d see if anyone was having the same issue. The text of the error is below, and I have screen captures as well if that would be helpful. The text of the error shows up two to four times on each page I open.

    user warning: Unknown column ‘captcha_type’ in ‘field list’ query: SELECT module, captcha_type FROM captcha_points WHERE form_id = ‘search_theme_form’ in /hermes/web08/b1270/pow.newbabbage/htdocs/drupaltest/modules/captcha/captcha.inc on line 60.

    • Edward Pearse Edward Pearse April 5, 2011

      I’ve been getting the same error – usually highlighted in a lovely pink box at the top!

      • Mr Underby Mr Underby May 29, 2011

        On the old Ning there used to be a feature that if a blog or image was yours (meaning you created it) you had the power to delete comments within.

        Is it possible to have that feature here?

         

  24. Edward Pearse Edward Pearse June 7, 2011

    Can we get the uploaded images to default one gallery or another? Seems VAST numbers of people are not selecting a gallery when they upload their pictures, so once the picture drops off the “recent history” sidebar the only way to find it is via the uploader’s profile.

    So if you didn’t check the forum for a couple of days (I know, unthinkable right?!?) you won’t even know a picture has been created.

    • Bookworm Hienrichs Bookworm Hienrichs June 10, 2011

      The way I handle it is:

      If the picture is a stand-alone thing, then I put it in one of the galleries.

      If, however, it’s part of a blog post, then I don’t, because I want people to see and comment on the entire blog post, not just the picture.

  25. Jedburgh30 Dagger Jedburgh30 Dagger September 1, 2011

    Pasting out of Word 2007 is an exercise in futility.  It picks up some kind of embedded characters and screws up the formatting.

    • Cyan Icewolf Cyan Icewolf November 14, 2011

      I think the easiest way to deal with copy and pasting is to disable rich text for that posting.

  26. Cyan Icewolf Cyan Icewolf November 14, 2011

    Well since I’m back I’m also back to help with Admin (sorry for being gone so long).

    Anyway just took a look at the issues for all projects and was wondering the stutus of them and if we should get rid of the ones past a year old just because of age or relook at them?

    • Edward Pearse Edward Pearse November 14, 2011

      There are a couple that are over a year old that I’d still like to see implemented:

      The ability to follow/subscribe to a post without having to actually post a comment

      The ability to delete a comment (for double posts or logging in under the wrong account or something).

      Maybe make a list?

      And welcome back. :-)

      • Cyan Rayna Cyan Rayna November 14, 2011

        Thanks!

        Maybe if we restart this thread and make a list of the list to see what people still want and still needs to be fixed. Some things I think are fixed but just haven’t been marked as such. Either way it’s always good to see what people want to do to improve the site.

        Will try and at the very least make the list later tonight when I am not at work XP

  27. Cyan Rayna Cyan Rayna November 15, 2011

    Okay Issues still on the list that are over a year old:

    Delete own Comments
    Better User Profiles
    Drop Down Menu for Character Status (IC, OOC)
    Profile Photo Link
    Follow Content without a comment
    Attach to event causes an error
    Personal Galleries
    TinyMCE Strikethrough and Underline
    Fix PNG Thumbnails
    Rich Text no longer adding paragraphs
    Login for this site should also work for the Wiki

  28. Cyan Rayna Cyan Rayna November 22, 2011

    I’ve been noticing the site take a bit of time to load (especially if you are using a smart phone) and not sure what exactly is making it take so long. Does anyone else have this experience?

  29. Nathaniel Lorefield Nathaniel Lorefield December 14, 2011

    Noticed today that under the Build Registry North Fells has not been added as a sim option yet. Granted, there aren’t too many builds there but still.

    • Cyan Rayna Cyan Rayna December 14, 2011

      I will play around with it and see what I can do… and hopefully not make it worse.

      • Cyan Rayna Cyan Rayna December 14, 2011

        It doesn’t have the link but does have the Sim name up.

        I also noticed that for some reason your Inspiration for the build isn’t showing. Not sure why it’s not but will put it on the issues list.

  30. Cyan Rayna Cyan Rayna December 27, 2011

    Redid the Widget for Twitter as it was collecting Spam somehow. Should be better now.

  31. Mr Tenk Mr Tenk September 3, 2012

    got a validation error when trying to comment on kimika’s comfort station post.

    • Cyan Rayna Cyan Rayna September 3, 2012

      I looked into our report section and didn’t see an error there nor have I seen anything helpful on the drupal website so not sure what happened. Have you tried posting it again, or anything specific you were putting in there (code, images, etc)?

  32. Mr Tenk Mr Tenk October 29, 2012

    Recurring events always display as Dec. 31

  33. Mr Tenk Mr Tenk November 13, 2012

    Add note to registration page for applicant to contact one of the moderators inworld with the name they are registering under, as the inworld naming convention changes have made it increasingly difficult to sort out an avatar from a canadian viagra salesbot. Mods can only send out a limited number of emails a day to verify that it is a real person on the other end, and the bots have been relentless.

  34. Mr Tenk Mr Tenk January 2, 2013

    event calendar defaults to 31 December on front page display if no time is entered in the hour field.

  35. Cyan Rayna Cyan Rayna January 14, 2014

    It’s been a while and want to fix up the site some more although will probably have to talk to Cleanslate to see if the Project Module was turned off for a reason (why I can’t edit the main page atm)

    Anyway I was thinking it would be high time to make a few changes once more if possible. If anyone has any suggestions please feel free to add them below.

    A few things that I know that are still on the list:

    Dates for multiple events show the start date as the end of the year

    Updated profiles

    … and think that’s it off hand.

    I have been away from actually fulltime maintenance of the site so don’t know what is wrong and what would be good to add so that’s why I am asking.

  36. Mr Tenk Mr Tenk June 1, 2014

    I am getting increasingly concerned about how long this page takes to load if you are logged in, and I know there are people who would like to participate more but the wait is just too long. On some days, I have to refresh several times to get to the page rather than timing out on a blank screen. 

    Curiously, if you are not logged in, the page loads instantly (even for me on my bandwidth), although you might not see the latest updates that you would see if you were logged in. 

    I’d call this a critical issue. 

    • Cyan Rayna Cyan Rayna June 1, 2014

      I’ve actually noticed the front page doesn’t load quickly at all and sometimes when you refresh doesn’t load at all in my case (which just happened btw).

      I’m not sure what is causing it but will look into it. We may even need to upgrade to the newest version (cause I think we are only on drupal 6 and 7 is out currently with 8 on the way). 

      I will look into this issue though and see what could be causing it.

      • Stargirl Macbain Stargirl Macbain June 1, 2014

        I’ve been doing an experiment this week and noticed that everything loads quickly on the BAR EXCEPT for the homepage. I’ve bookmarked a random photo and that loads quick as a snap and I’ve been navigating to the individual pages from there.

        I had a webpage I built doing something similar to this problem and it was a bad line of code in a homepage module. It might have been the GCalendar feed (it was over a year ago so I don’t remember the specifics). When it loaded everything was just fine, but often the whole page would time-out often. Replaced out the module on the homepage and everything suddenly worked just fine. Could be something along those lines?

         

         

        • Cyan Rayna Cyan Rayna June 2, 2014

          I started looking into the bad lines of code and started using the Devel Module we added (it gives some developer tools basically). One of the cool things it did was showed me what was happening when you loaded the front page. The sad thing it looks like the forum and the blog blocks might be the cause of this. Of course this is measured in milliseconds. but still the site took 2610.27 ms. I wish I could figure out exactly what the data is telling me but because it’s the front page I think it’s just loading a lot, a lot of times.

          I saved all the data to a google doc if anyone is interested in looking it over just message me. I will probably try and play with it again and get a longer amount of time from refresh to see if it will take longer again (as 2.6 seconds doesn’t sound like a long load time) and see what Devel says about it then.

          • Stargirl Macbain Stargirl Macbain June 16, 2014

            I would like to take a peek at the report., I’ll send you an offline tonight when I get home.

            • Cyan Rayna Cyan Rayna June 16, 2014

              message steampunkskunk at gmail and I will give you access. I’ve only done it twice and have both recorded in google docs.

    • Cyan Rayna Cyan Rayna June 5, 2014

      I removed the calendars, as you suggested, and it seems to load much quicker on my end… when the web server isn’t acting up.

      I’m still going to look into updating though as we are far behind on drupal itself as well as many of the modules we have but probably going to try it offline first as I don’t want to screw up the site as I did last time I tried to make updates.

      Would almost really like to wait for version 8 which is in alpha right now but I don’t know how long it will take to get out of alpha.

      Please let me know though if the calendar removal does help with speed.

    • Cyan Rayna Cyan Rayna June 16, 2014

      Since we have removed the two calendars from the main page it seems to load much more smoothly but still constantly (for me at least) have a reload that gives you a blank page and still have to reload the site once again, a problem I am told others experience as well.

      I’m testing something on my personal site currently though and will see if it will be easily tranferable to Babbage if it works the same way as the current site does.

      [edit] although I just did get an odd error with drupaltest in it and wondering now if it’s still active and could be the cause of it. I think two sites loading at the same time from one database could be an issue.

      • Edward Pearse Edward Pearse June 16, 2014

        Is it worth deleting the drupaltest version and putting in a simple redirect to the reader one?

        • Cyan Rayna Cyan Rayna June 16, 2014

          Probably. Although need to figure out how to do it.

          • Stargirl Macbain Stargirl Macbain June 16, 2014

            If it’s anything like Joomla it’s just matter of dropping the redirect in to the root via FTP. If you need one I can snag one off one of my websites and pass it to you.

            If the website is pulling information from two different websites to build the homepage, that might explain all the load errors. But it’s being out of date might also be the problem as developers stop updating for our version.

            • Cyan Rayna Cyan Rayna June 16, 2014

              I messaged Cleanslate to see if I can once again gain access to the root site/powweb in order to make changes. 

  37. Cyan Rayna Cyan Rayna October 27, 2014

    Been a while since I have been updating this but fixed the twitter feed mostly. it doesn’t auto-scroll anymore because twitter changed how the feed works but at least it searches for the #newbabbage hashtag once more. Also with the twitter feed working it moves the bug and feature request section out of the stream.

    I’m actually taking classes in web design at school and also been playing with wordpress lately so may look into seeing if we can fix up the site with that possibly but dunno. Don’t want to switch the whole system but drupal seems to drag a lot. WordPress seems a lot easier to deal with and offers much of the same stuff. Like I said will look into it but not promising anything.

    As always let me know if there’s something I can fix and I will look into it.

Leave a Reply